Refresh with USMT & SEP

Hi All,

I've been breaking my head with this and found a solution (not the one I'm proud of, but found it).

Basically, if you want migrate from from any version of Windows to another version of Windows (let's say Windows XP to Windows 7), you'll probably need capture the user profile and restore it.

As customer have multiple sites, we decied to use SMP (State Migration Point) and let ConfigMgr decide where is the best option to save/restore the data.

To start, we installed SMP on a DP and used X:\USMTData for the SMP folder.

After that, normal TS to capture user profile and we're testing, but it was stuck.

Looking log files, i couldn't see any problem

Scanstate.log showed
2012-03-15 11:06:29, Info                  [0x0801e7] Finalizing catalog (21326 entries).  Catalog is now in read-only mode.
2012-03-15 11:06:29, Info                  [0x080000] Catalog optimizations for <computername>\administrator: BeginOffset: 0, EndOffset: 0
2012-03-15 11:06:29, Info                  [0x080000] Catalog optimizations for <domain>\<username>: BeginOffset: 121538, EndOffset: 7841494
2012-03-15 11:06:29, Info                  [0x080000] Catalog optimizations for <domain>\<username>: BeginOffset: 7877726, EndOffset: 14781182
2012-03-15 11:06:29, Info                  [0x080000] Catalog optimizations for <computername>\guest: BeginOffset: 0, EndOffset: 0
2012-03-15 11:06:29, Info                  [0x080000] Catalog optimizations for system: BeginOffset: 0, EndOffset: 0
2012-03-15 11:06:29, Info                  [0x0801ed] Catalog at C:\Windows\Temp\tmp3008.tmp\Temp\tmp3A36.tmp has been successfully finalized (21326 entries)
2012-03-15 11:06:29, Info                  [0x080000] Media Manager: Storing catalog
2012-03-15 11:06:29, Status                [0x000000] Processing File catalog.mig

And scanstateprogress showed
15 Mar 2012, 11:06:15 +00:00, 00:02:05, totalPercentageCompleted, 85
15 Mar 2012, 11:06:19 +00:00, 00:02:09, totalPercentageCompleted, 91
15 Mar 2012, 11:06:28 +00:00, 00:02:17, totalPercentageCompleted, 95
15 Mar 2012, 11:06:28 +00:00, 00:02:17, PHASE, Saving

navigate to folders on both client and servers and the size of the files were different and when I removed the SEP, everything worked fine. A machine without SEP was working fine...

My conclusion was: the SEP is causing the issue, but i cannot remove SEP, what can I do?!?!?!?!!?

Basically, we decide to add exclusions to SEP Client on Clients
1- Exclusion based on extension .MIG
2- Exclusion based on extension .TMP
3- Exclusion based on path c:\Windows\Temp

and ConfigMgr Servers
1- Exclusion based on extension .MIG
2- Exclusion based on path X:\USMTData

After this, we restarted the machine and started the process again and this time, everything worked fine.