Failed to restore virtual machine state

I thought I would blog this since, for a moment, I thought I'd lost my DC and ConfigMgr server in my lab (Backups?? Sorry??)

Basically when attempting to start up my VM's from a saved state I received the following error message:

'failed to restore virtual machine state'

A quick check of the environment and it looked like the VM's were attempting to launch on an old virtual switch that no longer existed. Now this may or may not have been the cause but if I changed them to use the current virtual switch then they still failed to launch. Not good!

Next stop to power off the devices and see if I can change the settings. Hmm unfortunately there's no option to 'Turn Off' the devices when they are in a saved state from the Hyper-V console.

Thankfully PowerShell comes to the rescue with the Stop-VM command https://technet.microsoft.com/en-us/library/hh848468(v=wps.630).aspx 

So the machine is in a Saved state

I opened up PowerShell, typed in Stop-VM -Name DC and was prompted to effectively pull the plug on the device.

Back at the Hyper-V console the device is now Off.

I changed the device to use the currently virtual switch and Hey Presto! The device powered up successfully. 

As I say, I'm not sure if the virtual switch was the cause but this got me up and running and thankfully stopped me having to rebuild my lab.

***UPDATE***

Ok so this isn't a virtual switch problem. I can replicate it again. If I put my VM's into a saved state I can't power them back up. I'm currently running Windows 10 build 10532 so this may be an issue with this O/S release.