Recently I upgraded my ConfigMgr hierarchy to R3 – went very smoothly….so I thought anyway.

Later on I tried to create a reporting services report on my central site server and received the following error in the admin console GUI

System.Collections.Generic.KeyNotFoundException: The given key was not present in the dictionary.
   at System.ThrowHelper.ThrowKeyNotFoundException()
   at System.Collections.Generic.Dictionary`2.get_Item(TKey key)
   at Microsoft.ConfigurationManagement.AdminConsole.SrsReporting.CreateReportInfoPage.OnAddSummary(SummaryRequestHandler handler)
   at Microsoft.ConfigurationManagement.AdminConsole.SmsWizardForm.OnAddSummary(SummaryRequestHandler handler, SmsWizardPage thisPage)
   at Microsoft.ConfigurationManagement.AdminConsole.SmsWizardForm.OnAddSummary(SummaryRequestHandler handler)
   at Microsoft.ConfigurationManagement.AdminConsole.SmsWizardForm.Apply()
   at Microsoft.ConfigurationManagement.AdminConsole.ActionsWizardPage.OnActivated()
   at Microsoft.ConfigurationManagement.AdminConsole.WizardFramework.WizardPage.Activate()
   at Microsoft.ConfigurationManagement.AdminConsole.WizardFramework.WizardForm.OnNext()
   at System.Windows.Forms.Control.OnClick(EventArgs e)
   at System.Windows.Forms.Button.OnMouseUp(MouseEventArgs mevent)
   at System.Windows.Forms.Control.WmMouseUp(Message& m, MouseButtons button, Int32 clicks)
   at System.Windows.Forms.Control.WndProc(Message& m)
   at System.Windows.Forms.ButtonBase.WndProc(Message& m)
   at System.Windows.Forms.Button.WndProc(Message& m)
   at System.Windows.Forms.Control.ControlNativeWindow.WndProc(Message& m)
   at System.Windows.Forms.NativeWindow.Callback(IntPtr hWnd, Int32 msg, IntPtr wparam, IntPtr lparam)

My first thought was oh **** as usual I was doing other things whilst upgrading the servers…..could it have been something I changed….

 

I looked in the SMSAdminUI.log and saw the following

[3][24/05/2011 11:02:42] :Unable to retreive the Server Properties for 'SERVER'
[3][24/05/2011 11:02:53] :Unable to retreive the Server Properties for 'SERVER'
[3][24/05/2011 11:02:59] :Unable to retreive the Server Properties for 'SERVER'
[3][24/05/2011 11:03:11] :An error occured in ConfigMgr. The ConfigMgr console will continue to function, however you should save your work and restart the console. After restarting the console, verify that your last configurations have been applied.

Not very helpful, could it be rights related?

I thought I would check the internet, Bing.com returned nothing relevant and neither did that less known search engine Google.com

After several hours checking more logs and security settings in SRS and ConfigMgr I was running out out time so I rang PSS. Turns out is a known problem, KB2449910

Perhaps I had better work on my internet search skills…..

Anonymous